Linux JDK 1.7升级1.8版本

Linux wangleiadmin 1781℃ 0评论
线下java测试没问题,运行到线上环境出现 :Unsupported major.minor version 52.0 (unable to load class com.XXXX.SignServlet)
查了一下,说是版本问题!
java -version
java version "1.8.0_111"     线下

java -version
java version "1.7.0_67"      线上       #版本果然不同

升级JDK版本
下载:JDK 1.8
网址:http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html
jdk-8u111-linux-x64.rpm
服务器端:rpm -ivh  jdk-8u111-linux-x64.rpm    #jdk会默认安装在/usr/java/jdk1.8.0_111
配置环境变量:vim /etc/profile
文件尾部添加:
export PATH USER LOGNAME MAIL HOSTNAME HISTSIZE HISTCONTROL
export JAVA_HOME=/usr/java/jdk1.8.0_111       #如果拥有这些变量只需要改此处的目录位置
export CLASSPATH=.:%JAVA_HOME%/lib/dt.jar:%JAVA_HOME%/lib/tools.jar
export PATH=$PATH:$JAVA_HOME/bin

source /etc/profile  

java -version 

java version "1.8.0_111"
Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.111-b14, mixed mode)                  #版本已经更改!!


转载请注明:暖风 » Linux JDK 1.7升级1.8版本

喜欢 (0)
发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址